Elevated file rendering times

Incident Report for Waymark

Resolved

This incident has been resolved.
Posted Jul 06, 2023 - 18:15 EDT

Investigating

We're experiencing a backup in our video rendering service. Until this is resolved, you may have longer than usual wait times for completed videos to be available for download.
Posted Jul 06, 2023 - 14:30 EDT
This incident affected: Video Rendering Service.